Source | Text Version

QSN-4058-1: bash vulnerability

July 15, 2019

Summary

A system hardening measure could be bypassed.

Details

It was discovered that Bash incorrectly handled the restricted shell. An attacker could possibly use this issue to escape restrictions and execute any command.

References

https://usn.ubuntu.com/4058-1

http://people.canonical.com/~ubuntu-security/cve/CVE-2019-9924

Update

A general update will usually fix all issues, but to make sure, you can check your current version with:

$ dpkg -l bash

If the current version you have is before 4.3-14ubuntu1.4, run the following:

$ sudo apt-get update
$ sudo apt-get install bash

Copyright © 2010-2015, OSNEXUS Corporation. All rights reserved.